Get in touch
Back
Maintenance

Hardware update

Completed 27 Oct at 08:00am CEST.

Viking system uptime status
Completed

Maintenance completed

Posted 27 Oct at 08:00am CEST.
Started

A hardware and software update.

Posted 26 Oct at 06:00pm CEST.